Module 7

Maintenance and Security

Objectives
1. 1.7 Perform preventive maintenance procedures
2. 1.8 Basic OS security settings
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PREVENTIVE MAINTENANCE
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Safe Mode
1. A diagnostic mode of a Windows OS
2. Reduced functionality
3. Disables many non-core components
4. Intended to fix most, if not all problems within an
operating system
5. Used to remove rogue security software
6. An installation that will only boot into its safe
mode typically has a major problem
7. Accessed through msconfig or F8 at startup
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Task Manager
1. Ways to access:
A.Right-click the Taskbar and select Task
Manager
B.[Ctrl]+[Shift]+[Esc]
C.Click the Start button and type taskmgr in the
Start Search box, and press [Enter].
D.[Ctrl]+[Alt]+[Delete] and can click Start Task
Manager.
For more information about the Task Manager
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Task Manager
Applications tab
1. Operates exactly the same as it did in XP and
Vista
2. Allows you to determine
the status of a task as
well as end, switch, or
create a new task
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Task Manager
Processes tab
1. Provides detailed process information
2. More information available, just pull down the View menu and
choose the Select Columns command:
A. The Image Path Name setting
shows the full path to the file
behind the running process
B. The Command Line setting shows
the full command line, including
the parameters or switches used
to launch the process
3. Other useful information about a
particular process can be viewed by
right-clicking on a process and
selecting the Open File Location or
Properties commands
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Task Manager
Services tab
1. View the services that are running or available
2. If you want to investigate
whether a running service is
tied to a particular process,
you can right-click on the
service name and select the
Go to Process command
3. If you need more control, click
the Services button to launch
the Services mmc
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Task Manager
Performance tab
1. Shows the performance of the CPU and RAM
2. In the Physical Memory section:
A. The Total entry shows the amount of RAM installed in the
system
B. The Cached entry shows the
amount of physical memory used
for system resources
C. The Available entry shows the
amount of physical memory not
being used
3. In the Kernel Memory section:
A. The Paged and Nonpaged entries
show you how much of it is coming
from virtual memory and how
much is coming from physical memory
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Task Manager
Performance tab
4. In the System section:
A. The Handles entry shows the number of object
identifiers that are currently in use by all running processes
B. The Threads entry refers to the number of
sub-processes running inside
of larger processes
C. The Processes entry shows the
number of currently running processes
D. The Up Time entry shows the
amount of time that has passed
since the computer has been
restarted
E. The Commit entry shows Page File
usage
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Task Manager
1. The Networking tab shows the network status
and usage
2. The Users tab shows who is logged on to the
system
Student
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System Configuration Tool
1.msconfig
2. Can help identify problems that might prevent
Windows from starting correctly
3. Tabs include:
A.General
B.Boot
C.Services
D.Startup
E.Tools
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Scheduling Backups
1. Found under Control Panel, System and Maintenance, Backup and
Restore
2. You can:
A. Click backup or restore and then follow the wizard
B. Create a system image
C. Create a system repair disc
3. Recommendations:
A. Don't back up your files
to the same hard disk
that Windows is installed
on
B. Always store backup
media in a secure and
fireproof place offsite
C. Create a regular schedule
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Scheduling Check Disks
1. Can help solve some computer problems
and improve the performance of your
computer by making sure that your hard
disk has no errors
2. Open Computer > right-click the hard disk
drive that you want to check > Properties >
Tools tab > under Error-checking
click Check Now
3. To automatically repair problems with files
and folders that the scan detects, select
Automatically fix file system errors
4. To perform a thorough disk check, select both
Automatically fix file system errors and Scan for and
attempt recovery of bad sectors

14

Scheduling Disk Defragmenter
1. Rearranges fragmented data on a volume so it will work more
efficiently
2. Scheduling makes it run at regular intervals when your
computer is turned on
3. It is scheduled to run once a week by default
4. Can be changed
5. Open Computer > right-click the hard
disk drive that you want to check >
click Properties > Tools tab > under
Defragmentation, click Defragment Now
6. Can't be scheduled for solid-state
drives (SSD), as well as some types
of virtual hard disks (VHD)
7. You can defragment manually
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Windows Updates
1. Helps keep your PC safer and your software current
2. Automatic updating
A. Important updates provide significant benefits, such as improved
security and reliability
B. Recommended updates address noncritical problems
3. Optional updates are installed manually
4. Open Windows Update by clicking the
Start button > All Programs >
Windows Updates
A. To change what gets updated
click Change settings in the left pane >
choose the option that you want
B. Under Recommended updates, select
the Give me recommended updates
the same way I receive important
updates check box
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Driver Updates
1. A driver is software that allows your computer to communicate
with hardware devices
2. Windows can automatically check if there are drivers available
for new devices that you connect to your computer
3. For older hardware, updated drivers might become available
but aren't installed automatically
4. To install these optional updates, go to
Windows Update > check for updates
> then view and install driver updates
that are available
5. You can manually install drivers
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Antivirus Updates
1. Must be updated regularly to stay effective against
new viruses
2. Most is designed to update automatically, but you
can update your software manually
3. Windows does not come with antivirus software, but
can often detect and monitor
antivirus software installed
4. Status is displayed in Action Center
5. Open Action Center by clicking
the Start button > Control Panel >
Action Center > in the Security
section look for Virus Protection
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System Restore
1. Can return your PC's system files and programs to a
time when everything was working fine
2. It won't affect your documents, pictures,
or other data
3. Open System Restore by clicking
the Start button > Control Panel >
System > click Advanced system
settings on the left > System
Protection tab > System Restore
4. Before you start System Restore,
save any open files and close all
programs
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Automated System Recovery (ASR)
1. Create an ASR disk as part of an overall plan for system
recovery in case of system failure
2. Use as a last resort in system recovery
3. You can access the Automated System Recovery
Preparation Wizard from Backup
4. This backs up the System State data, system services,
and all disks associated with the operating system
components
5. Does not include data files
6. To restore select Start > Control
Panel > Backup and Restore >
create a system repair disc on
the left > select a drive >
then click create disc
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BASIC SECURITY
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Users and Groups
1. A user group or security group is a collection of user accounts that
all have the same security rights
2. A user account can be a member of more than one group
3. The two most common user groups are the standard user group and
the administrator group
4. An administrator account can create custom user groups, move
accounts from one group to another, and add or remove accounts
from different groups
5. When you create a custom user group, you
can choose which rights to assign
6. Cannot be completed on Windows 7 Starter,
Windows 7 Home Basic, and Windows 7
Home Premium
7. To open select Start > Control Panel >
Administrative Tools > Computer Management
> Local Users and Groups in the left pane
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Administrative Shares
1. The default network shares
2. These default shares share every hard drive partition in the system
3. These shares will allow anyone who can authenticate as any
member of the local Administrators group access to the root
directory of every hard drive on the system
4. Are not accessible by default on home
editions of XP, Vista or Windows 7
5. The "$" appended to the end of the share
name means that it's a hidden share
A. \\MyComputer\C$
B. \\MyComputer\ADMIN$ (shares
access to %SYSTEMROOT%)
6. To view shares select Start > Control
Panel > Administrative Tools >
Computer Management > click Shard
Folders in the left pane > Shares
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Share Permissions
1. Only apply to users who access the resource over the
network
2. When you share a folder by default the “Everyone” group
is given the read permission
3. It applies to all files and folders in the
shared resource
4. Does not apply if you use terminal
services, mapped drives, the Run
command, or local user
5. Use Security Permissions to secure
these
6. Security permissions are not available
on FAT or FAT32 file systems
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Share Permissions
1. Command line:
A.cacls filename /G user:permission (grant
access to user)
B.cacls filename /D user:permission (deny
access to user)
C.cacls filename /P user:permission (replace
user access)
D. Permissions
•
•
•
•
•

N (None)
R (Read)
W (Write)
C (Change)
F (Full control)
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Security Permissions
1. Applies to users logged on locally, terminal
services, mapped drives, the Run
command
2. Provides a more secure access
3. Can only be set on a volume that is
formatted to the NTFS file system
4. Effective permissions are the result of
combining the user’s assigned
permissions and the permissions of any
groups the user belongs to
5. You should apply both shared and security
permissions
6. Remove the “Everyone” access
7. Careful when using the “Administrators”
group because anyone with “Administrator”
privileges will have access
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Summary
In this Module we discussed:
1. Safe Mode
2. Task Manager
3. Msconfig
4. Scheduling Backups
5. Scheduling Check Disk
6. Scheduling Defragmentation
7. Windows Updates
8. Driver Updates
9. Antivirus Updates
10.System Restore
11.Automated System Recovery
12.User and Group Permissions
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Glossary and Terms
Safe Mode – A diagnostic mode of Windows
msconfig – Microsoft System Configuration
Task Manager – System Monitor Application
Kernel – The basic windows OS application that manages the input/output
between hardware and software.
5. Paged memory – Memory usage performed by the operating system that
transfers data between main memory and a hard drive.
6. Process – An instance of a computer program being executed.
7. Thread – Code execution inside a process.
8. SSD – Solid State Drive
9. VHD – Virtual Hard Disk
10. Fragment – A non-contiguous data file.
11. Driver – Software that bridges a hardware device to the operating system.
12. Action Center – A component of Windows that provides users with the
ability to view the status of computer security and maintenance.
13. ASR – Automated System Recovery
1.
2.
3.
4.
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